Error: The subscription plan in Stripe could not be created, please try again.

This topic contains 34 replies, has 3 voices, and was last updated by  patrik 1 month, 2 weeks ago.

  • Author
    Posts
  • #3062

    TLN
    Buyer
    Post count: 131

    Thanks for the reply Guust. I believe my customer tried to use the discount just once, and she got the error mentioned. Perhaps I am wrong, but it seems that I have to clear Stripe test data every time I try to use the discount code, even if its for a different user.

    #3063

    TLN
    Buyer
    Post count: 131

    Here’s a great example of what I’m describing. This lady (user ID 154) tried to sign up today. She does not have a subscription, and is a brand new user. She created her listing and went to the check out page. Then, she tried to use a discount code and encountered the following error (see screenshot “stripe error 1”):

    request POST body
    {
    “id”: “standard-listing_1883_299_799_month_0”,
    “amount”: “799”,
    “currency”: “USD”,
    “interval”: “month”,
    “interval_count”: “1”,
    “product”: {
    “id”: “1883”,
    “name”: “Standard Listing ($2.99 for the first month. Then $7.99 for each month.)”
    }
    }
    Response body
    {
    “error”: {
    “code”: “resource_already_exists”,
    “doc_url”: “https://stripe.com/docs/error-codes/resource-already-exists”,
    “message”: “Product already exists.”,
    “type”: “invalid_request_error”
    }
    }

    she then tried multiple times and ended up getting another error (see screenshot “stripe error 2”)

    Attachments:
    You must be logged in to view attached files.
    #3078

    TLN
    Buyer
    Post count: 131

    I’ve deactivated discount codes for now since they are not working for us. Pretty much it seems that there’s an issue with using discount codes with Stripe . Please see my previous posts and screenshots showing Stripe error.

    Thanks!

    #3081

    Guust
    Moderator
    Post count: 26743

    Let’s keep going here.
    Please restore admin access for the user so we can have a look.

    #3084

    TLN
    Buyer
    Post count: 131

    Ok. I should be able to do this tomorrow. We can even set Stripe to test mode if you guys like and I can provide access to the logs there as well.

    #3108

    TLN
    Buyer
    Post count: 131
    This reply has been marked as private.
    #3109

    Guust
    Moderator
    Post count: 26743

    Both your monthly discount codes are set to be used only once by each user.

    I changed both codes to be allowed more than once by the same user and all works fine now.
    Please check.

    #3110

    TLN
    Buyer
    Post count: 131

    Does not work for me, or any of my advertisers. We have not once been able to use coupons successfully if we pay using Stripe.

    I’ve attached a screenshot showing my outcome after using your coupon “checkout”. It is the same error as before under a new username.

    Also, why do your test listings show “never” for the expiration date? the expiration date is supposed to be 30 days from now. Are you entering the listings from the front end? Thanks for the help.

    Attachments:
    You must be logged in to view attached files.
    #3113

    TLN
    Buyer
    Post count: 131

    I want to dispel the notion that this has to do with a user using the coupon multiple times since this has come up again and again. I have tried creating a new user every time, and it still does not work. My advertisers have never been able to use a coupon, even though it is their first time checking out.

    #3114

    TLN
    Buyer
    Post count: 131

    It seems to be working again, it’s very strange. Basically, the codes started working again after I deleted the Stripe test data. It doesn’t make much sense.

    #3115

    TLN
    Buyer
    Post count: 131

    I made another discovery… if you change the coupon in any way it stops working.

    #3116

    Guust
    Moderator
    Post count: 26743
    This reply has been marked as private.
    #3117

    Guust
    Moderator
    Post count: 26743
    This reply has been marked as private.
    #3118

    TLN
    Buyer
    Post count: 131
    This reply has been marked as private.
    #3119

    TLN
    Buyer
    Post count: 131
    This reply has been marked as private.
Viewing 15 posts - 16 through 30 (of 35 total)

The topic ‘Error: The subscription plan in Stripe could not be created, please try again.’ is closed to new replies, this may be for inactivity, please open a new topic if you have a similar question.